Take Command 25.0:

 

Take Command:

 

Take Command utilise beaucoup moins de CPU lorsque vous avez plusieurs onglets et que vous n'utilisez pas de groupes d'onglets ou de fenêtres divisées.

 

La communication entre Take Command et TCC est beaucoup plus rapide et utilise moins de temps CPU.

 

Le découpage des ombres du cadre, le chevauchement et la mise à l'échelle sont corrigés dans les environnements multi-moniteurs et multi-DPI.

 

De nombreuses incohérences des thèmes Office 2013/2016 et Visual Studio 2015 ont été corrigées.

 

La prise en charge DPI a été améliorée pour les contrôles Edit, Checkbox et Combobox.

 

Vous pouvez modifier la transparence de la fenêtre TCMD avec Ctrl-Shift-Mousewheel.

 

Vous pouvez désormais désenregistrer n'importe quel système, à condition que vous disposiez de la clé d'activation d'origine et du nom de l'ordinateur à désenregistrer. La boîte de dialogue d'enregistrement comporte un champ "Nom du système" pour le nom de l'ordinateur (qui est par défaut le système actuel). Entrez le nom et cliquez sur le bouton « Désinscrire » pour supprimer le système spécifié. TCMD ouvrira une page Web sur votre navigateur avec le résultat de la désinscription.

 

Vous pouvez désormais générer une clé manuelle (qui ne nécessite pas d'activation Internet) sur n'importe quel système, à condition que vous disposiez de la clé d'activation d'origine et du nom de l'ordinateur à enregistrer, et que le système sur lequel vous demandez la clé ait accès à Internet. La boîte de dialogue d'enregistrement comporte un champ "Nom du système" pour le nom de l'ordinateur (qui est par défaut le système actuel). Entrez le nom et cliquez sur le bouton "Demander une clé manuelle". TCMD ouvrira une page Web sur votre navigateur qui renvoie la clé manuelle. Copiez cette valeur de clé et saisissez-la dans le champ « Clé d'activation » dans la boîte de dialogue d'enregistrement sur l'ordinateur que vous souhaitez enregistrer.

 

Vous pouvez maintenant afficher vos informations de licence sur le serveur d'enregistrement. Affichez la boîte de dialogue d'enregistrement, entrez votre clé d'activation et cliquez sur le bouton "Afficher les informations de licence". TCMD ouvrira une page Web sur votre navigateur indiquant le nombre maximum de systèmes que vous pouvez enregistrer, le(s) nom(s) des systèmes enregistrés et les dates auxquelles ils ont été enregistrés.

 

Ajout d'une nouvelle entrée au menu Accueil / Fichier :

 

Effacer le tamponSupprimez le contenu du tampon d'écran de la fenêtre de l'onglet actuel.

 

Ajout d'une nouvelle entrée au menu Edition :

 

Copier+AjouterAjoutez la sélection actuelle au contenu du presse-papiers existant.

 

Ajout d'une nouvelle entrée au menu Onglets (et au menu contextuel lors d'un clic droit sur l'étiquette d'un onglet) :

 

Détacher+MasquerDétache l'onglet, mais le garde caché. Il peut être refixé avec l'option « Attacher les onglets ».

 

Le menu contextuel du clic droit de la fenêtre de l'onglet comporte une nouvelle option : "Copier+Ajouter" ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

Si l'option de sélection Linux est activée, lorsque vous marquez un bloc et relâchez le bouton gauche de la souris avec la touche Maj enfoncée, TCMD ajoutera la sélection au presse-papiers.

 

Si l'option de sélection Linux est activée, lorsque vous double-cliquez avec la touche Maj enfoncée, TCMD ajoutera la sélection au presse-papiers.

 

Si l'option de sélection Linux est activée, lorsque vous triple-cliquez avec la touche Maj enfoncée, TCMD ajoutera la ligne au presse-papiers.

 

Une touche Ctrl-W fermera l'onglet actuel (comme Ctrl-F4), à condition que vous ayez activé la touche de contrôle gauche ou droite pour Take Command. (Voir OPTIONS / Take Command /Onglets/Fenêtres.)

 

Une touche Ctrl-Maj-C ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

Le champ de saisie Scintilla a été mis à jour vers la version 4.2.0.

 

L'analyseur d'expressions régulières (Outils / RegEx) dispose désormais d'un minuteur en microsecondes (à droite du contrôle d'édition "Test") qui mesure le temps nécessaire pour évaluer l'expression.

 

L'analyseur d'expressions régulières dispose d'une « aide-mémoire » sur la syntaxe RE et les expressions courantes.

 

Vous pouvez faire glisser le Take Command fenêtre hors de l'écran ("Console Quake") et redescendez avec Ctrl-Alt-Entrée.

 

Vous pouvez mettre en surbrillance la ligne où se trouve le curseur avec la nouvelle directive CursorLineColor dans TCMD.INI. Réglez-le avec OPTIONS / Take Command / Onglets / Fenêtres / Ligne de curseur.

 

Si vous modifiez la taille de la police de la fenêtre de l'onglet avec Ctrl-molette de la souris ou les options du menu zoom avant/zoom arrière, la nouvelle taille de police n'est appliquée qu'à la fenêtre de l'onglet actuelle ; Ainsi, chaque fenêtre d'onglet peut avoir sa propre taille. (À terme, chaque fenêtre d'onglet prendra également éventuellement en charge sa propre police, mais pas dans cette version.)

 

If Take Command plante ou est tué par une autre application, les fenêtres masquées de la console seront affichées après 5 secondes, afin qu'elles puissent être fermées ou rattachées.

 

 

TCC:

 

TCC a été largement réécrit pour prendre en charge le multithreading (presque) partout. Par exemple, un plugin peut exécuter d'autres commandes internes, alias et fichiers batch sans entrer en conflit avec le thread principal. Notez que cela ne signifie pas que les API de la console Windows prennent en charge le multithreading : si vous effectuez une sortie à partir de plusieurs threads simultanément, vous obtiendrez une sortie confuse. En raison des limitations de Windows, la gestion des événements de la console (^C, ^Break, arrêt, déconnexion, etc.) n'est vue et traitée que par le thread principal.

 

TCC est compatible avec le nouveau terminal Windows 10 (actuellement en avant-première).

 

Modification de certaines des DLL les moins couramment utilisées pour qu'elles soient chargées à la demande, ce qui réduira légèrement le temps de démarrage et l'empreinte RAM.

 

Toutes les bibliothèques Internet/réseau/zip IPWorks ont été mises à jour.

 

La bibliothèque d'expressions régulières Onigmo a été mise à jour.

 

Ajout de la prise en charge de Python 3.8.

 

Vous pouvez désormais désenregistrer n'importe quel système, à condition que vous disposiez de la clé d'activation d'origine et du nom de l'ordinateur à désenregistrer. La boîte de dialogue d'enregistrement comporte un champ "Nom du système" pour le nom de l'ordinateur (qui est par défaut le système actuel). Entrez le nom et cliquez sur le bouton « Désinscrire » pour supprimer le système spécifié. TCC ouvrira une page Web sur votre navigateur avec le résultat de la désinscription.

 

Vous pouvez désormais générer une clé manuelle (qui ne nécessite pas d'activation Internet) sur n'importe quel système, à condition que vous disposiez de la clé d'activation d'origine et du nom de l'ordinateur à désenregistrer, et que le système sur lequel vous demandez la clé ait accès à Internet. La boîte de dialogue d'enregistrement comporte un champ "Nom du système" pour le nom de l'ordinateur (qui est par défaut le système actuel). Entrez le nom et cliquez sur le bouton "Demander une clé manuelle". TCC ouvrira une page Web sur votre navigateur qui renvoie la clé manuelle. Copiez cette valeur de clé et saisissez-la dans le champ « Clé d'activation » de la boîte de dialogue d'enregistrement.

 

Vous pouvez maintenant afficher vos informations de licence sur le serveur d'enregistrement. Affichez la boîte de dialogue d'enregistrement, entrez votre clé d'activation et cliquez sur le bouton "Afficher les informations de licence". TCMD ouvrira une page Web sur votre navigateur indiquant le nombre maximum de systèmes que vous pouvez enregistrer, le(s) nom(s) des systèmes enregistrés et les dates auxquelles ils ont été enregistrés.

 

Le caractère générique [ ] accepte désormais soit ! or ^ comme symbole NON.

 

Les fenêtres contextuelles d'historique et d'historique de répertoire prennent désormais en charge la sélection multiple (avec les touches Maj ou Ctrl + souris gauche) et disposent d'un menu contextuel contextuel (bouton droit de la souris) pour copier, copier + ajouter, couper ou supprimer. Vous pouvez également sélectionner plusieurs entrées et les exécuter en appuyant sur Entrée - TCC va créer une ligne de commande qui ressemble à ceci :

 

(line1) & (line2) & (line3)

 

Il existe de nouvelles options pour la redirection de sortie. Ces options remplaceront les directives UnicodeOutput et UTF8Output dans TCMD.INI. Les options de sortie canalisée fonctionnent également avec les canaux DOS (c'est-à-dire |!:u). Remarque : ces options ne fonctionnent que pour rediriger la sortie de TCC commandes internes.

 

>:unLa sortie redirigée (STDOUT et/ou STDERR) est ANSI (caractères 8 bits)
>:tuLa sortie redirigée est UTF16 Unicode
>:8 ou >:u8La sortie redirigée est UTF8

 

>>:unLa sortie redirigée ajoutée (STDOUT et/ou STDERR) est ANSI (caractères 8 bits)
>>:tuLa sortie redirigée ajoutée est UTF16 Unicode
>>:8 ou >>:u8La sortie redirigée ajoutée est UTF8

 

|:uneLa sortie canalisée est ANSI
|:tuLa sortie canalisée est UTF16 Unicode
|:8 ou |:u8La sortie canalisée est UTF8

 

La colorisation du répertoire (DIR, PDIR, SELECT) prend désormais en charge les plages de la variable COLORDIR ou de la directive ColorDir .INI. Voir DIR ci-dessous pour plus de détails.

 

La colorisation des répertoires (DIR, PDIR, SELECT) prend désormais en charge les types de sous-systèmes (Win32, Win64, GUI, CUI) dans la variable COLORDIR ou la directive ColorDir .INI. Voir DIR ci-dessous pour plus de détails.

 

Les plages de dates et d'heures peuvent désormais comparer les heures UTC en ajoutant un « U » après le D ou le T (et les options A, C ou W) dans la spécification de la plage. Par exemple:

 

/[twu00:00,11:59]

 

Les plages de tailles peuvent désormais tester la taille compressée (sur les lecteurs NTFS avec la compression activée pour le fichier ou le répertoire) en ajoutant un C à l'argument S. Par exemple, pour spécifier des fichiers dont la taille compressée est comprise entre 100 et 1000 XNUMX octets :

 

/[sc100,1000]

 

L'analyseur d'expressions régulières (Ctrl-F7) dispose désormais d'un minuteur en microsecondes (à droite du contrôle d'édition "Test") qui mesure le temps nécessaire pour évaluer l'expression.

 

L'analyseur d'expressions régulières dispose d'une « aide-mémoire » sur la syntaxe RE et les expressions courantes.

 

Vous pouvez faire glisser le TCC fenêtre hors de l'écran ("Console Quake") et redescendez avec Ctrl-Alt-Entrée. La séquence de touches est configurable à l'aide de la directive QuakeHotKey .INI ; voir ci-dessous.

 

Vous pouvez minimiser le TCC fenêtre vers et depuis la barre d’état système avec Ctrl-Shift-Z. La séquence de touches est configurable à l'aide de la directive TrayHotKey .INI ; voir ci-dessous.

 

Réduction de l'utilisation du processeur dans TCC légèrement lorsque vous courez dans un Take Command fenêtre à onglets.

 

TCC détectera s'il s'exécute en tant que service ou s'il est détaché avant de demander une authentification SSL ou SSH, et fournira une entrée automatique « Y » (oui).

 

La directive FileCompletion .INI et la variable d'environnement prennent en charge un nouveau type :

 

library - Complétion par tabulation pour les noms de fonctions de bibliothèque

 

 

Débogueur IDE/batch :

 

Le champ de saisie Scintilla a été mis à jour vers la version 4.2.0.

 

Le redessin dans les fenêtres d'édition est plus fluide et plus rapide.

 

Amélioration des temps de chargement et d'enregistrement des fichiers volumineux.

 

Lors du chargement d'un fichier, l'IDE vérifiera d'abord le type de fichier (UTF-16, UTF-8, UTF-8 avec BOM ou ANSI). Si le fichier n'a pas de nomenclature UTF-16 ou UTF-8, il est lu en tant que fichier ANSI avec la page de codes de la console actuelle et converti en UTF-8 avant d'être modifié. Il sera reconverti en fichier ANSI avec la page de codes actuelle lors de son enregistrement. Cela permet à l'EDI d'afficher correctement les caractères ASCII à bits élevés dans l'éditeur.

 

Le débogueur batch a une nouvelle "Commande Expansion" fenêtre qui apparaîtra au-dessus de la fenêtre de l'onglet lorsque vous démarrez le débogage. La commande Expansion La fenêtre affichera la ligne de commande d'origine, la ligne de commande après l'expansion de l'alias et la ligne de commande après l'expansion des variables. La commande Expansion window est une fenêtre d'ancrage, elle peut donc être déplacée et attachée à d'autres emplacements. Si vous ne voulez pas voir la commande Expansion fenêtre, vous pouvez le désactiver à partir de l'option de menu "Affichage / Expansion des commandes" de l'EDI.

 

Vous pouvez désormais accéder en une seule étape aux groupes de commandes et aux boucles FOR. Cliquez sur le bouton "Step Into" dans la barre d'outils de l'EDI. Vous verrez la ligne de commande actuelle en cours d'exécution dans la fenêtre "Command Expansion" (voir ci-dessus).

 

L'onglet "Modifié" comporte une nouvelle colonne "Précédent" qui affiche la valeur précédente de la variable qui vient d'être modifiée.

 

Lors du débogage, la fenêtre IDE gardera désormais la ligne actuelle centrée sur l'écran (sauf si elle se trouve sur la dernière page). Cela vous permet de voir à la fois les dernières lignes et les suivantes à exécuter.

 

Vous pouvez modifier la transparence de la fenêtre IDE avec Ctrl-Shift-Mousewheel.

 

Les fenêtres Watch, Modified et Breakpoint enregistreront désormais les largeurs de colonnes si vous les modifiez et utiliseront les nouvelles largeurs lorsque vous redémarrerez l'EDI.

 

La fenêtre d'édition gardera désormais la ligne actuelle en surbrillance même si elle n'est pas mise au point.

 

La fenêtre d'édition conservera par défaut la même indentation que la ligne précédente. La valeur par défaut peut être modifiée avec l'option EnsureIndent dans TCMD.INI (voir ci-dessous).

 

La recherche d'expressions régulières (boîte de dialogue Rechercher) utilise désormais la bibliothèque d'expressions régulières C++11 au lieu de la prise en charge limitée précédente des expressions régulières.

 

Le minuteur du profileur utilise désormais les compteurs de performances Windows. La résolution est désormais en millisecondes (001 seconde) au lieu de centièmes (01 seconde).

 

Si vous utilisez TCC syntaxe (pas CMD), et la première commande de la ligne est une commande interne TCC commande, l’EDI affichera l’aide d’utilisation rapide sur la barre d’état.

 

Ajout d'un nouveau sous-menu au menu Fichier :

 

CodageLes fichiers sont toujours traités en UTF-8 dans l'éditeur. Cette option vous permet de spécifier comment le fichier sera écrit lorsqu'il sera enregistré sur le disque.        

 

Page de codes par défautLorsque le fichier est enregistré, il sera écrit en utilisant la page de codes actuelle
UTF16 Petit-EndienUne fois le fichier enregistré, il sera écrit au format UTF-16
UTF8Une fois le fichier enregistré, il sera écrit au format UTF-8
UTF8 avec nomenclatureLorsque le fichier est enregistré, il sera écrit au format UTF-8 avec une nomenclature en tête.

 

Ajout d'une nouvelle entrée au menu Edition :

 

Copier+AjouterAjoutez la sélection actuelle au contenu du presse-papiers existant.

 

Ajout d'un nouveau sous-menu au menu Edition :

 

Caractères de fin de ligne

 

CR + LFLes lignes se terminent par un retour chariot + un saut de ligne (Windows par défaut)
CRLes lignes se terminent par un retour chariot (OSX par défaut)
LFLes lignes se terminent par un saut de ligne (Linux par défaut)

 

Ajout d'une nouvelle entrée au menu Edition / Avancé :

 

Basculer le pli actuel - active et désactive le pliage de la ligne actuelle

 

Ajout de deux nouvelles entrées pliantes au menu Affichage. (Cela sera un peu déroutant si vous n'activez pas la marge de pliage dans le menu Options !)

 

Basculer le pli actuel - active et désactive le pliage de la ligne actuelle

Basculer tous les plis - bascule chaque pli du fichier

 

Ajout d'une nouvelle entrée au menu Débogage :

 

Évaluer la commande : exécute la commande spécifiée dans le contexte du fichier de commandes en cours d'exécution. La sortie est affichée dans un contrôle d’édition défilant en lecture seule. Notez que la commande que vous exécutez peut modifier le résultat du débogage du fichier batch.

 

Le menu contextuel du clic droit de la fenêtre de l'onglet comporte une nouvelle option : "Copier+Ajouter" ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

Une touche Ctrl-Maj-C ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

L'analyseur d'expressions régulières (Outils / Expressions régulières...) dispose désormais d'un timer en microsecondes (à droite du contrôle d'édition "Test") qui mesure le temps nécessaire à l'évaluation de l'expression.

 

L'analyseur d'expressions régulières dispose d'une « aide-mémoire » sur la syntaxe RE et les expressions courantes.

 

Les fenêtres Surveillance, Modifié et Points d'arrêt afficheront désormais une info-bulle au survol de la souris contenant le texte intégral d'une colonne, si elle est trop large pour être affichée entièrement dans la colonne.

 

Si vous "sortez" (exécutez jusqu'au point d'arrêt ou à la fin) et que vous êtes dans un fichier de commandes CALL, et s'il n'y a plus de points d'arrêt dans le fichier actuel, vous serez renvoyé au fichier de commandes parent à la ligne suivant le APPELEZ, et « sortez » sera désactivé.

 

Le débogueur n'enregistrera pas de fichier *.watch si les seules variables surveillées sont celles par défaut ? et _?.

 

 

TCEDIT:

 

Le champ de saisie Scintilla a été mis à jour vers la version 4.2.0.

 

Amélioré le TCEdit le temps de démarrage.

 

Amélioration des temps de chargement et d'enregistrement des fichiers volumineux.

 

Lors du chargement d'un fichier, TCEdit vérifiera d'abord le type de fichier (UTF-16, UTF8, UTF-8 avec BOM ou ANSI). Si le fichier n'a pas de nomenclature UTF-16 ou UTF-8, il est lu en tant que fichier ANSI avec la page de codes de la console actuelle et converti en UTF-8 avant d'être modifié. Il sera reconverti en fichier ANSI avec la page de codes actuelle lors de son enregistrement. Ceci permet TCEdit pour afficher correctement les caractères ASCII à bits élevés.

 

Le redessin dans les fenêtres d'édition est plus fluide et plus rapide.

 

Vous pouvez changer le TCEdit transparence de la fenêtre avec Ctrl-Shift-Mousewheel.

 

La fenêtre d'édition gardera désormais la ligne actuelle en surbrillance même si elle n'est pas mise au point.

 

La fenêtre d'édition conservera par défaut la même indentation que la ligne précédente. La valeur par défaut peut être modifiée avec l'option EnsureIndent dans TCMD.INI (voir ci-dessous).

 

La recherche d'expressions régulières (boîte de dialogue Rechercher) utilise désormais la bibliothèque d'expressions régulières C++11 au lieu de la prise en charge limitée précédente des expressions régulières.

 

Ajout d'un nouveau sous-menu au menu Fichier :

 

CodageLes fichiers sont toujours traités en UTF-8 dans l'éditeur. Cette option vous permet de spécifier comment le fichier sera écrit lorsqu'il sera enregistré sur le disque.        

 

Page de codes par défautLorsque le fichier est enregistré, il sera écrit en utilisant la page de codes actuelle
UTF16 Petit-EndienUne fois le fichier enregistré, il sera écrit au format UTF-16
UTF8Une fois le fichier enregistré, il sera écrit au format UTF-8
UTF8 avec nomenclatureLorsque le fichier est enregistré, il sera écrit au format UTF-8 avec une nomenclature en tête.

 

Ajout d'une nouvelle entrée au menu Edition :

 

Copier+AjouterAjoutez la sélection actuelle au contenu du presse-papiers existant.

 

Ajout d'un nouveau sous-menu au menu Edition :

 

Caractères de fin de ligne

 

CR + LFLes lignes se terminent par un retour chariot + un saut de ligne (Windows par défaut)
CRLes lignes se terminent par un retour chariot (OSX par défaut)
LFLes lignes se terminent par un saut de ligne (Linux par défaut)

 

Ajout d'une nouvelle entrée au menu Edition / Avancé :

 

Basculer le pli actuel - active et désactive le pliage de la ligne actuelle

 

Ajout de deux nouvelles entrées pliantes au menu Affichage. (Cela sera un peu déroutant si vous n'activez pas la marge de pliage dans le menu Options !)

 

Basculer le pli actuel - active et désactive le pliage de la ligne actuelle

Basculer tous les plis - bascule chaque pli du fichier

 

Le menu contextuel du clic droit de la fenêtre de l'onglet comporte une nouvelle option : "Copier+Ajouter" ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

Une touche Ctrl-Maj-C ajoutera la sélection actuelle au contenu existant du presse-papiers.

 

 

Aidez-moi:

 

L'aide est construite avec une nouvelle version de Help & Manual 7.

 

 

Directives TMCD.INI :

 

CursorLineColor - Définissez la couleur de la ligne où se trouve le curseur (fenêtres de l'onglet TCMD uniquement). Réglez-le avec OPTIONS / Take Command / Onglets / Fenêtres / Ligne de curseur.

 

EscResetHistory=yes|NO - Si OUI, TCC réinitialisera le pointeur de l’historique des commandes à la fin de la liste lorsque vous appuierez sur Échap à l’invite de commande.

 

MaintenirIndent=YES|no - Dans l'EDI & TCEdit éditez les fenêtres, utilisez la même indentation que sur la ligne précédente.

 

QuakeHotKey (Entrée par défaut) - Touche de raccourci pour faire glisser le Take Command or TCC fenêtres "style Quake". Le raccourci clavier est toujours Ctrl-Alt-quelque chose ; la valeur de QuakeHotKey est la dernière valeur. Par exemple, pour la valeur par défaut Ctrl-Alt-Entrée : :

 

QuakeHotKey=Entrée

 

RepeatArgument - Duplique l'argument précédent sur la ligne de commande (par défaut, Shift-F12).

 

ScreenUpdate - Nombre d'images par seconde pour le Take Command mises à jour des fenêtres de l'onglet. La plage est de 1 à 100 ; la valeur par défaut est 30.

 

TrayHotKey (par défaut Ctrl-Shift-Z) - Déplacez le Take Command or TCC fenêtre vers et depuis la barre d’état système.

 

Activation de la section (obsolète, obsolète, non recommandée) [Secondaire].

 

 

Modification de la ligne de commande :

 

Ajout d'une solution de contournement pour le bug de Windows 10 pour permettre l'utilisation des touches de sélection (c'est-à-dire Maj-Gauche, etc.) sans activer la console héritée.

 

Shift-F12 (RepeatArgument) dupliquera l'argument précédent sur la ligne de commande.

 

Ctrl-Backspace - identique à Ctrl-L (supprimer le mot à gauche).

 

Ctrl-Suppr - identique à Ctrl-R (supprimer le mot à droite).

 

Modification de la valeur par défaut TCC Touche d'édition "Annuler" de Alt-Z à Ctrl-Maj-Z (Windows 10 consommera la touche Alt-Z à moins que vous ne définissiez l'option "console héritée".)

 

Modification de la valeur par défaut TCC Touche d'édition "refaire" de Alt-Y à Ctrl-Shift-Y (Windows 10 consommera la touche Alt-Y sauf si vous définissez l'option "console héritée".)

 

 

Nouvelles variables internes :

 

Il existe un certain nombre de nouvelles variables internes pour la position et l'état GPS. Ils nécessitent un GPS (interne ou externe) prenant en charge les API de localisation des capteurs Windows. Notez que votre GPS peut ne pas prendre en charge toutes les variables ; si une valeur n'est pas prise en charge, Windows renverra "Élément introuvable". Sauf indication contraire, les valeurs renvoyées sont des nombres décimaux (par exemple, 38.735122).

 

%_gpsalt - Altitude (par rapport au niveau de la mer) en mètres.

 

%_gpsazimuth - Azimut de chaque satellite en vue. Renvoie une liste délimitée par des espaces.

 

%_gpselevation - Altitude de chaque satellite visible. Renvoie une liste délimitée par des espaces.

 

%_gpserrorradius - Précision des valeurs de latitude et de longitude, en mètres.

 

%_gpsfixquality - Qualité du correctif (entier).

 

%_gpsfixtype - Type du correctif (entier).

 

%_gpshdop - Dilution horizontale de précision.

 

%_gpsheading - Cap vrai.

 

%_gpsids - ID des satellites visibles. Renvoie une liste d'entiers délimités par des espaces.

 

%_gpslat - Latitude

 

%_gpslon - Longitude

 

%_gpsmagheading - Cap magnétique.

 

%_gpsnmea - Renvoie la phrase NMEA sous forme de chaîne.

 

%_gpsopmode - Mode de fonctionnement GPS (entier).

 

%_gpspdop - Dilution de précision de position.

 

%_gpsprns - Numéros PRN de satellites en vue. Renvoie une liste d'entiers délimités par des espaces.

 

%_gpssatsinview - Nombre de satellites visibles (entier)

 

%_gpssatsused - Nombre de satellites utilisés dans la solution (entier).

 

%_gpsselmode - Mode de sélection GPS (entier).

 

%_gpssnr - Rapport signal/bruit de chaque satellite en vue. Renvoie une liste délimitée par des espaces.

 

%_gpsspeed - Vitesse en nœuds.

 

%_gpsstatus - Statut GPS (entier).

 

%_gpsvdop - Dilution verticale de précision.

 

 

Nouvelles fonctions variables :

 

@VARTYPE - Renvoie le type (le cas échéant) pour le nom de variable spécifié. Les valeurs possibles sont :

 

0Aucun type
1Entier (0-9)
2Décimal (0-9, le caractère décimal et le séparateur des milliers)
3Hex (0-9, AF)
4Booléen (0 ou 1)
5Alphabétique (A-Z et a-z)
6Alphanumérique (A-Z, a-z et 0-9)
7Expression régulière

 

@WINPATH - Convertir du format de chemin d'accès WSL au format Windows. Par exemple:

 

echo %@winpath[//mnt/c/windows/system32/notepad.exe]

c: \ windows \ system32 \ notepad.exe

 

@WSLPATH - Convertir du format de chemin d'accès Windows au format WSL. Par exemple:

 

echo %@wslpath[c:\windows\system32\notepad.exe]

//mnt/c/windows/system32/notepad.exe

 

 

Fonctions variables mises à jour :

 

@EVAL - ajout de la fonction log2().

 

@PID - ajout d'un deuxième argument facultatif qui spécifie s'il faut renvoyer tous les PID correspondant au premier argument. Par exemple:

 

@pid[firefox,+]

 

@MINUTEUR - Utilise désormais les compteurs de performances Windows pour une résolution plus élevée. La résolution @TIMER par défaut est en millisecondes (001 seconde) au lieu de centièmes (0.01 seconde). @TIMER a trois nouvelles valeurs pour le deuxième argument facultatif pour renvoyer le temps intermédiaire sous forme de valeur arithmétique :

 

ms - temps intermédiaire en millisecondes

nous - temps intermédiaire en microsecondes

ns - temps intermédiaire en nanosecondes

 

@VERSION - ajout d'un nouveau 5ème paramètre facultatif qui spécifie s'il faut ajouter le numéro de version au nom de fichier (0) ou le préfixer à l'extension (1).

 

 

Plugins:

 

Les plugins peuvent désormais exécuter n'importe quelle commande (alias, interne, fichier batch, etc.) sans entrer en conflit avec le principal TCC thread de traitement (voir TCC au dessus de).

 

 

Commandes mises à jour :

 

ACTIVER

 

/POS - accepte un * valeur pour l’un des arguments. Si la valeur est *, ACTIVATE utilisera la valeur de position/largeur/hauteur existante. Par exemple, pour redimensionner une fenêtre sans la déplacer :

 

ACTIVER "titre" /POS=*,*,1200,800

 

Pour déplacer une fenêtre sans la redimensionner :

 

ACTIVER "titre" /POS=200,400,*,*

 

ASSOCIÉ

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

/V:verb- ASSOCIATE lit et écrit par défaut dans SHELL\OPEN\COMMAND. Vous pouvez utiliser un verbe différent en spécifiant l'option /V. Par exemple, pour indiquer de créer un verbe PRINT pour les fichiers .TXT :

 

ASSOCIÉ /V:PRINT .txt=%%SystemRoot%%\system32\NOTEPAD.EXE /p %%1

 

ATTRIB

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

CHCP

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

COULEUR

 

COLOR prend désormais en charge la modification de la palette de couleurs de la console avec soit un fichier .INI (par exemple, tel qu'utilisé par l'utilitaire ColorTool), soit un fichier .ITERMCOLORS. La syntaxe est :

 

COULEUR /F nom de fichier

 

Si vous courez dans un Take Command fenêtre d'onglet, COLOR transmettra les nouvelles couleurs à TCMD pour mettre à jour la fenêtre d'onglet. Vous pouvez avoir une palette de couleurs différente dans chaque fenêtre d'onglet.

 

DIR

 

La colorisation des répertoires (à l'aide de la variable d'environnement COLORDIR ou de OPTION / Couleurs / Couleurs du répertoire) prend désormais en charge tous les types de gammes (taille, date, heure, description, propriétaire et exclusion). La syntaxe est la même que pour les plages d'une commande interne. Par exemple, pour afficher les fichiers faisant entre 100 et 1000 XNUMX octets en vert vif :

 

set colordir=/[s100,1000]:bri vert;

 

La colorisation des répertoires prend désormais en charge les couleurs pour les types de sous-systèmes de fichiers. Les sous-systèmes pris en charge sont :

 

EXETYPE_WIN32GUIApplication graphique Windows x86
EXETYPE_WIN32CUIApplication console Windows x86
EXETYPE_WIN64GUIApplication graphique Windows x64
EXETYPE_WIN64GUIApplication console Windows x64
EXETYPE_DOSApplication DOS (16 bits) (obsolète)
EXETYPE_POSIXApplication POSIX (obsolète)
EXETYPE_EFIApplication EFI

 

Par exemple, pour afficher les applications de console 32 bits en vert vif et les applications de console 64 bits en rouge vif :

 

set colordir=EXETYPE_WIN32CUI:bri vert;EXETYPE_WIN64CUI:bri rouge

 

/-C - Supprime les séparateurs de milliers lors de l'affichage de la taille des fichiers (pour compatibilité avec CMD.EXE).

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

SERVEURS ÉNUMÉRATEURS

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

ENUMSHARES

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

TOUT

 

Le Take Command / TCC la distribution inclut désormais ES.EXE, l'interface de ligne de commande pour TOUT (y compris une version x64 pour Windows x64).

 

POUR

 

Le format ~a (attributs d'affichage) a été mis à jour pour correspondre au comportement actuel de CMD avec les attributs étendus (y compris le comportement de CMD consistant à ne pas afficher tous les attributs étendus).

 

GOSUB

 

GOSUB prend désormais en charge l'appel de sous-programmes dans un autre fichier lorsque ce fichier est compressé.

 

TÊTE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

IF

 

ISVISIBLE "titre" - exécute la commande si la fenêtre spécifiée est visible. (Cela signifie que Windows a activé l'indicateur de visibilité ; cela ne signifie pas que la fenêtre est nécessairement visible sur votre bureau.

 

IFF

 

ISVISIBLE "titre" - exécute la commande si la fenêtre spécifiée est visible.

 

INSTALLÉE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

BIBLIOTHÈQUE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

PAUSE

 

/C - Après avoir appuyé sur une touche, efface l'invite et n'imprime pas de CR/LF.

 

PDIR

 

La colorisation des répertoires prend désormais en charge les plages (voir DIR pour plus de détails).

 

La colorisation des répertoires prend désormais en charge les types de sous-systèmes (voir DIR pour plus de détails).

 

/D - a changé la signification de "coloriser" à "ne pas coloriser" (pour correspondre à DIR et SELECT).

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

BRANCHER

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

Print

 

/S imprimante - définir l'imprimante par défaut.

 

PRIORITÉ

 

Si vous fournissez uniquement un PID ou un titre de fenêtre, PRIORITY affichera la priorité actuelle.

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

PROMPT

 

La résolution du minuteur PROMPT (= métachar) est désormais en millisecondes (001 seconde) au lieu de centièmes (01 seconde).

 

RÉPERTOIRE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

/X - affiche les valeurs REG_DWORD, REG_DWORD_BIG_ENDIAN et REG_QWORD en hexadécimal. Uniquement valide lorsqu'il est utilisé avec /V et /D.

 

SELECT

 

La colorisation des répertoires prend désormais en charge les plages (voir DIR pour plus de détails).

 

La colorisation des répertoires prend désormais en charge les types de sous-systèmes (voir DIR pour plus de détails).

 

SERVICES

 

/I - Affiche les PID des services. Notez que les services arrêtés renverront 0 pour le PID, tout comme les services Windows.

 

SYNC

 

/WAIT=n - Pause de n millisecondes entre chaque bloc copié de la source vers le fichier cible. Ceci est utile pour les réseaux lents et les copies de fichiers très volumineuses ; cela empêche SYNC de monopoliser toutes les E/S du réseau.

 

QUEUE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

tasklist

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

MINUTEUR

 

TIMER utilise désormais les compteurs de performances Windows pour une plus grande précision. La résolution TIMER par défaut est désormais en millisecondes (001 seconde) au lieu de centièmes (0.01 seconde).

 

/L - Lorsqu'il est utilisé avec /S (temps intermédiaire) ou TIMER OFF, affiche le résultat en nombre de millisecondes.

 

/M - Lorsqu'il est utilisé avec /S (temps intermédiaire) ou TIMER OFF, affiche le résultat en nombre de microsecondes.

 

/N - Lorsqu'il est utilisé avec /S (temps intermédiaire) ou TIMER OFF, affiche le résultat en nombre de nanosecondes.

 

TOUCHER

 

/CD - crée le répertoire spécifié s'il n'existe pas.

 

ARBRE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

TYPE

 

/Pn - l'option /P(ause) a un argument facultatif n qui spécifie le nombre de secondes à attendre pour une frappe avant de continuer.

 

UNQLITE

 

Mise à jour vers UnQLite 1.1.9.

 

VOIR

 

Prise en charge DPI par moniteur (Windows 10 Creators Update 1703 et supérieur). Cela signifie que V s'ajustera automatiquement lors du déplacement entre des moniteurs de différentes échelles.

Maj+clic sur l’en-tête de la colonne CSV pour sélectionner la colonne entière.

Commande Copier CSV pour copier les colonnes CSV (avec délimiteur) dans le presse-papiers.

Ajout de l'option de ligne de commande /QUIET pour l'impression.

 

FENÊTRE

 

/POS - accepte un * valeur pour l’un des arguments. Si la valeur est *, WINDOW utilisera la valeur position/largeur/hauteur existante. Par exemple, pour redimensionner une fenêtre sans la déplacer :

 

FENÊTRE /POS=*,*,1200,800

 

Pour déplacer une fenêtre sans la redimensionner :

 

FENÊTRE /POS=200,400 XNUMX,*,*